summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/swupdate/swupdate.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/swupdate/swupdate.mk b/package/swupdate/swupdate.mk
index 86bbf1431..9338fc83c 100644
--- a/package/swupdate/swupdate.mk
+++ b/package/swupdate/swupdate.mk
@@ -103,4 +103,12 @@ define SWUPDATE_INSTALL_TARGET_CMDS
cp -dpf $(@D)/www/* $(TARGET_DIR)/var/www/swupdate)
endef
+# Checks to give errors that the user can understand
+# Must be before we call to kconfig-package
+ifeq ($(BR2_PACKAGE_SWUPDATE)$(BR_BUILDING),yy)
+ifeq ($(call qstrip,$(BR2_PACKAGE_SWUPDATE_CONFIG)),)
+$(error No Swupdate configuration file specified, check your BR2_PACKAGE_SWUPDATE_CONFIG setting)
+endif
+endif
+
$(eval $(kconfig-package))