summaryrefslogtreecommitdiff
path: root/assembler/Makefile.am
diff options
context:
space:
mode:
authorAdam Sampson <ats@offog.org>2018-04-03 23:48:44 +0100
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-04-04 16:43:27 +0300
commit0e143039fd190f1d22d03f9617af69af3c48b076 (patch)
tree836d4c34507c1b45baa9da4e9e6051b24f630f1e /assembler/Makefile.am
parent2440f7220f6416156f3daf24dd073be396a44dcd (diff)
Test that register types are accepted in all valid forms.
The assembler should accept ub, :ub, UB and :UB. Signed-off-by: Adam Sampson <ats@offog.org> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'assembler/Makefile.am')
-rw-r--r--assembler/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/assembler/Makefile.am b/assembler/Makefile.am
index 855e33ab..49422e02 100644
--- a/assembler/Makefile.am
+++ b/assembler/Makefile.am
@@ -52,6 +52,7 @@ check_SCRIPTS = test/run-test.sh
TESTS = \
test/mov \
test/frc \
+ test/regtype \
test/rndd \
test/rndu \
test/rnde \