summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2013-12-10 09:23:44 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2013-12-10 09:23:44 +0100
commit831a47196dd4d8afbdd967353d689bf8aed4f3e6 (patch)
tree3d2809ecd44c850b8cf9cfbef0f6f5888f16bc3a /configure.ac
parent8c33e9ad111d27b84db4daac43809a807f262632 (diff)
lib: Add host platform to version string
This is import on systems where we compile 32bit tests that run on 64bit platforms. Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04035299..b43f45c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,7 @@ AC_CONFIG_AUX_DIR([build-aux])
AC_USE_SYSTEM_EXTENSIONS
AC_SYS_LARGEFILE
AC_GNU_SOURCE
+AC_CANONICAL_HOST
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_PATH_PYTHON([3],, [:])
@@ -185,6 +186,7 @@ if test "x$BUILD_TESTS" = xyes; then
AC_DEFINE(BUILD_TESTS, 1, [Build tests])
fi
AM_CONDITIONAL(BUILD_TESTS, [test "x$BUILD_TESTS" = xyes])
+AC_DEFINE_UNQUOTED(TARGET_CPU_PLATFORM, ["$host_cpu"], [Target platform])
AC_CONFIG_FILES([
Makefile