summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Widawsky <benjamin.widawsky@intel.com>2013-12-20 21:15:16 -0800
committerBen Widawsky <benjamin.widawsky@intel.com>2013-12-20 21:15:16 -0800
commit94b2b861f5e2cd3dd5e32459174c9fdc3c3b0d8b (patch)
treed30a119cd0227c2094bab7d76216b8cacf4f7071 /configure.ac
parent4f28614777a5dec5de5cafacd640f5b50180acaa (diff)
shader-debugger: Use in tree gen4asm
Reported-by: Patrick McMunn <doctorwhoguy@gmail.com> Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 10 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b43f45c7..55cc78fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,13 +133,20 @@ if test "x$DUMPER" == xyes; then
fi
AM_CONDITIONAL(HAVE_DUMPER, [test "x$DUMPER" = xyes])
-# Define a configure option for the shadder debugger
+# Define a configure option for the shader debugger
AC_ARG_ENABLE(shader-debugger, AS_HELP_STRING([--enable-shader-debugger],
[Enable shader debugging support [autodetected]]),
[BUILD_SHADER_DEBUGGER="$enableval"], [BUILD_SHADER_DEBUGGER=auto])
-# Shadder debugger depends on python3, intel-genasm and objcopy
+# Shader debugger depends on python3, intel-genasm and objcopy
if test "x$BUILD_SHADER_DEBUGGER" != xno; then
+ GEN4ASM = assembler/intel-gen4asm
+ # Check that the assembler is built
+ if test "$enable_assembler" = xno; then
+ AC_MSG_ERROR([Shader debugger requested, but assembler not build not found.])
+ BUILD_SHADER_DEBUGGER=no
+ fi
+
# Check Python 3 is installed
if test "$PYTHON" = ":" ; then
if test "x$BUILD_SHADER_DEBUGGER" = xyes; then
@@ -148,15 +155,7 @@ if test "x$BUILD_SHADER_DEBUGGER" != xno; then
BUILD_SHADER_DEBUGGER=no
fi
fi
- # Check for the Intel Chipset assembler compiler
- AC_PATH_PROGS([GEN4ASM], intel-gen4asm)
- if test -z "$GEN4ASM" ; then
- if test "x$BUILD_SHADER_DEBUGGER" = xyes; then
- AC_MSG_ERROR([Shader debugger requested, but intel-gen4asm not found.])
- else
- BUILD_SHADER_DEBUGGER=no
- fi
- fi
+
# Check for the objcopy GNU binary utiliy command
AC_PATH_PROGS([OBJCOPY], objcopy)
if test -z "$OBJCOPY" ; then