summaryrefslogtreecommitdiff
path: root/debugger/Makefile.am
diff options
context:
space:
mode:
authorBen Widawsky <ben@bwidawsk.net>2011-06-24 11:42:03 -0700
committerBen Widawsky <ben@bwidawsk.net>2011-07-28 14:26:57 -0700
commit62873796c4a96554cc139e9aa49e25ce19cd65cd (patch)
tree94ec773aca3881e696bd6f1067ec16beb4056e9a /debugger/Makefile.am
parente39b13d7e4174ec50fd41d74fe8d3375c8ef2850 (diff)
intel-gpu-tools/debugging: shader debugger
high level summary of the files: * debug_rdata - get current state from debug registers. Helpful when developing the debugger, and could serve some purpose in the future. * eudb - the debugger itself * eviction_macro - generate the proper macro to flush the EU render cache until I get control flow working * pre_cpp - an evaluating c preprocesser like thing, to be used before cpp * sr - the system routine, exception handler which runs on the EU * test - a very basic test system routine * debug.h
Diffstat (limited to 'debugger/Makefile.am')
-rw-r--r--debugger/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/debugger/Makefile.am b/debugger/Makefile.am
new file mode 100644
index 00000000..eff4e2db
--- /dev/null
+++ b/debugger/Makefile.am
@@ -0,0 +1,12 @@
+SUBDIRS=system_routine
+
+bin_PROGRAMS = \
+ eudb \
+ debug_rdata \
+ $(NULL)
+
+LDADD = ../lib/libintel_tools.la $(DRM_LIBS) $(PCIACCESS_LIBS)
+
+AM_CFLAGS = $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(WARN_CFLAGS) \
+ -I$(srcdir)/.. \
+ -I$(srcdir)/../lib