summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2013-07-24 09:46:57 +0200
committerDaniel Vetter <daniel.vetter@ffwll.ch>2013-07-24 12:52:01 +0200
commit24bbca9237cbb6bd5e85db839dc517db65e693e8 (patch)
treed00e9d90e1f08db8630b05e3d61a995b62c5a6b8 /tests/Makefile.am
parentdfe942edec1a713568a19e15ce75e1ed01b9fb08 (diff)
tests/gem_flink_race: actually make it somewhat useful
- Enable subtest support. - Add a check for the same flink name in the racing threads, which is an issue one of my recent patches actually fixes. - Add the test I've actually wanted to write which races an flink against gem close (with no open in between). That one does indeed leak. - Readd the leak check, but note that this needs a fixed kernel. Otherwise the leak counter will be utter garbage. Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5ad38fda..a59c25fa 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,6 +25,7 @@ TESTS_progs_M = \
gem_exec_nop \
gem_fence_thrash \
gem_flink \
+ gem_flink_race \
gem_gtt_concurrent_blit \
gem_linear_blits \
gem_mmap_gtt \
@@ -61,7 +62,6 @@ TESTS_progs = \
gem_exec_faulting_reloc \
gem_exec_lut_handle \
gem_fenced_exec_thrash \
- gem_flink_race \
gem_gtt_cpu_tlb \
gem_gtt_speed \
gem_hangcheck_forcewake \