summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2013-08-12 10:43:59 +0200
committerDaniel Vetter <daniel.vetter@ffwll.ch>2013-08-12 11:17:58 +0200
commit7553ad6e10f76aa703359a10e08138e14501d54d (patch)
tree1e778fa0a06bf91bdc43aa2574be555396e42d5c /tests/Makefile.am
parenta4038d3853b98707a803f5d1fb5c9ebe32f0b84b (diff)
tests: use drmtest_skip() in caching ioctl helpers
This way we can rip out all the skip handling from the test control flow, and additionally (by using drmtest_retval()) even get correct exit codes. The only tricky part is that when we only want ot skip parts of a test (like for gem_pread and gem_pwrite) we need to split out those parts as subtests. But no addition of control-flow is required, the set/longjmp magic in the helpers all makes it happen. Also we make extensive use of the behaviour of drmtest_skip to skip all subsequent subtests if it is called outside of a subtest. This allows us to re-flatten the control flow a lot. Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8fff22c3..f3475ada 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,8 +30,10 @@ TESTS_progs_M = \
gem_linear_blits \
gem_mmap_gtt \
gem_partial_pwrite_pread \
+ gem_pread \
gem_pread_after_blit \
gem_prw_concurrent_blit \
+ gem_pwrite \
gem_pwrite_pread \
gem_ringfill \
gem_set_tiling_vs_blt \
@@ -73,8 +75,6 @@ TESTS_progs = \
gem_mmap_offset_exhaustion \
gem_pin \
gem_pipe_control_store_loop \
- gem_pread \
- gem_pwrite \
gem_readwrite \
gem_reg_read \
gem_reloc_overflow \