summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2013-09-06 11:44:41 +0100
committerDamien Lespiau <damien.lespiau@intel.com>2013-09-30 18:04:22 +0100
commit951b37e2d0d69ef7c013bf3ee7a57f7d6bd15119 (patch)
tree67ec19961e6a17aa45f130322f9d25456c87f727 /tests/Makefile.am
parent5d996349137e368c7ad8a3b2ce708c77c006a2db (diff)
testdisplay: Provide a full path when opening pngs
This way one doesn't have to be in tests/ for testsdisplay to be able to open pass.png. Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c7209aff..99d98d6c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -194,7 +194,10 @@ CLEANFILES = $(EXTRA_PROGRAMS)
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) \
-I$(srcdir)/.. \
- -I$(srcdir)/../lib
+ -I$(srcdir)/../lib \
+ -DIGT_DATADIR=\""$(abs_srcdir)"\" \
+ $(NULL)
+
LDADD = ../lib/libintel_tools.la $(PCIACCESS_LIBS) $(DRM_LIBS)
testdisplay_SOURCES = \