summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-11-30 15:20:29 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2009-11-30 15:55:03 +0000
commit94a180c0c95d70983ca15ada1de5d8624a68211e (patch)
tree09c225fbfe60b9ce78a4ca25c90d40ff950bfe37 /tools/Makefile.am
parent9e9c9f24f5d5520ab6a2451aab7dc81d2abc8cdf (diff)
decode: Split decoder and reuse outside of intel_gpu_dump
Introduce a second decoder that simpler operates on a file so that it can be run on dumped batchbuffers independent of the gpu. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 8bb1509c..75edcacc 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,5 +1,6 @@
bin_PROGRAMS = \
intel_audio_dump \
+ intel_decode \
intel_gpu_dump \
intel_gpu_top \
intel_gpu_time \
@@ -9,6 +10,12 @@ bin_PROGRAMS = \
intel_gpu_dump_SOURCES = \
intel_gpu_dump.c \
+ intel_decode.c \
+ intel_decode.h
+
+intel_decode_SOURCES = \
+ intel_decode_file.c \
+ intel_decode.c \
intel_decode.h
LDADD = ../lib/libintel_tools.la $(DRM_LIBS) $(PCIACCESS_LIBS)