summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b9663690..3d18f736 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -60,10 +60,18 @@ TESTS_scripts = \
debugfs_reader \
$(NULL)
-TESTS = $(TESTS_progs) \
+kernel_tests = \
+ $(TESTS_progs) \
$(TESTS_scripts) \
$(NULL)
+TESTS = \
+ $(NULL)
+
+test:
+ whoami | grep root || ( echo not running as root; exit 1 )
+ make TESTS="${kernel_tests}" check
+
HANG = \
gem_bad_batch \
gem_hang \