summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d6de373c..dc864f4f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -27,18 +27,25 @@ multi-tests.txt: Makefile.sources
@echo ${multi_kernel_tests} >> $@
@echo END TESTLIST >> $@
-igt_tests_bin_PROGRAMS += \
+noinst_PROGRAMS = \
+ $(HANG) \
+ $(TESTS_testsuite) \
+ $(NULL)
+
+pkglibexec_PROGRAMS = \
+ gem_alive \
+ gem_stress \
$(TESTS_progs) \
$(TESTS_progs_M) \
$(NULL)
-dist_igt_tests_bin_SCRIPTS = \
+dist_pkglibexec_SCRIPTS = \
$(TESTS_scripts) \
$(TESTS_scripts_M) \
$(scripts) \
$(NULL)
-dist_igt_tests_data_DATA = \
+dist_pkgdata_DATA = \
$(IMAGES) \
$(NULL)
@@ -52,7 +59,7 @@ AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-I$(srcdir)/../lib \
-include "$(srcdir)/../lib/check-ndebug.h" \
-DIGT_SRCDIR=\""$(abs_srcdir)"\" \
- -DIGT_DATADIR=\""$(igt_tests_datadir)"\" \
+ -DIGT_DATADIR=\""$(pkgdatadir)"\" \
$(LIBUNWIND_CFLAGS) \
$(NULL)