summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 4 insertions, 19 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dc864f4f..11f7f965 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,26 +5,11 @@ if HAVE_NOUVEAU
endif
if BUILD_TESTS
-all-local: single-tests.txt multi-tests.txt
+all-local: test-list.txt
-list-single-tests:
- @echo TESTLIST
- @echo ${single_kernel_tests}
- @echo END TESTLIST
-
-list-multi-tests:
- @echo TESTLIST
- @echo ${multi_kernel_tests}
- @echo END TESTLIST
-
-single-tests.txt: Makefile.sources
- @echo TESTLIST > $@
- @echo ${single_kernel_tests} >> $@
- @echo END TESTLIST >> $@
-
-multi-tests.txt: Makefile.sources
+test-list.txt: Makefile.sources
@echo TESTLIST > $@
- @echo ${multi_kernel_tests} >> $@
+ @echo ${single_kernel_tests} ${multi_kernel_tests} >> $@
@echo END TESTLIST >> $@
noinst_PROGRAMS = \
@@ -52,7 +37,7 @@ dist_pkgdata_DATA = \
EXTRA_PROGRAMS = $(HANG)
EXTRA_DIST = $(common_files)
-CLEANFILES = $(EXTRA_PROGRAMS) single-tests.txt multi-tests.txt
+CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-I$(srcdir)/.. \