summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 5af4e515..dd2abd79 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -195,6 +195,7 @@ test_progs = [
'kms_vblank',
'meta_test',
'perf',
+ 'perf_pmu',
'pm_backlight',
'pm_lpsp',
'pm_rc6_residency',
@@ -262,9 +263,14 @@ endif
libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'), 'intel-gpu-tools')
foreach prog : test_progs
+ link = []
+ if prog == 'perf_pmu'
+ link += lib_igt_perf
+ endif
executable(prog, prog + '.c',
dependencies : test_deps,
install_dir : libexecdir,
+ link_with : link,
install : true)
endforeach