summaryrefslogtreecommitdiff
path: root/tools/gator/debian/rules
diff options
context:
space:
mode:
authorJon Medhurst <tixy@linaro.org>2012-05-04 14:39:28 +0100
committerJon Medhurst <tixy@linaro.org>2012-05-18 14:24:19 +0100
commit09f333ed6069575a71fabc999c4dc39b6594d727 (patch)
tree87c273fe093e5352d1285016fad017351af1f6a2 /tools/gator/debian/rules
parent8bed00134a4b0ba837c1b16effaec86cf35679e6 (diff)
gator: ubuntu: Add packaging
Files and scripts for creating Debian packages for Gator and ARM DS-5 target. Signed-off-by: Jon Medhurst <tixy@linaro.org>
Diffstat (limited to 'tools/gator/debian/rules')
-rwxr-xr-xtools/gator/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/gator/debian/rules b/tools/gator/debian/rules
new file mode 100755
index 00000000000..c747748ff83
--- /dev/null
+++ b/tools/gator/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ CROSS_COMPILE ?= $(DEB_HOST_GNU_TYPE)-
+endif
+
+export CROSS_COMPILE
+
+export DH_OPTIONS
+
+%:
+ dh $@