summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-11-01 10:18:08 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-01 14:51:15 +0100
commit2e29db7d979b58a72d0d7fc5eefb652abba971da (patch)
tree80cba632a1b98b46a25345146bca27d73b498e56 /boot
parentb3450a888d0764a4f4d31dcad483c7b6092225cd (diff)
package/uboot: define help commands when using Kconfig
Expose the Kconfig-related help commands when U-Boot uses the Kconfig configuration. Like others (like Linux, barebox, busybox), only expose menuconfig, not all the configurators. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/uboot.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index ae7539d51..3e347c108 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -181,6 +181,12 @@ endif # BR2_TARGET_UBOOT_USE_DEFCONFIG
UBOOT_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
UBOOT_KCONFIG_OPTS = $(UBOOT_MAKE_OPTS)
+define UBOOT_HELP_CMDS
+ @echo ' uboot-menuconfig - Run U-Boot menuconfig'
+ @echo ' uboot-savedefconfig - Run U-Boot savedefconfig'
+ @echo ' uboot-update-defconfig - Save the U-Boot configuration to the path specified'
+ @echo ' by BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE'
+endef
endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
define UBOOT_BUILD_CMDS