summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorHollis Blanchard <hollis_blanchard@mentor.com>2016-10-07 15:45:04 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-25 23:59:36 +0200
commitae3bb50a6c0075f9c1ac432ae101011446096aad (patch)
tree487094aa00d02cc03f720efcbef4e0a2cd324dec /boot
parent4f87aa7db5eef544f04659edffb04dfb1ab181df (diff)
boot-wrapper-aarch64: Allow users to select the PSCI SMP boot method
Signed-off-by: Hollis Blanchard <hollis_blanchard@mentor.com> [Thomas: - remove "default n" - pass explicit --disable-psci] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/boot-wrapper-aarch64/Config.in6
-rw-r--r--boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/boot/boot-wrapper-aarch64/Config.in b/boot/boot-wrapper-aarch64/Config.in
index c4e63e23d..73d790fed 100644
--- a/boot/boot-wrapper-aarch64/Config.in
+++ b/boot/boot-wrapper-aarch64/Config.in
@@ -32,4 +32,10 @@ config BR2_TARGET_BOOT_WRAPPER_AARCH64_BOOTARGS
Kernel bootargs to embed inside the image generated by the
boot wrapper.
+config BR2_TARGET_BOOT_WRAPPER_AARCH64_PSCI
+ bool "Boot secondary SMP cores using PSCI"
+ help
+ Boot secondary SMP cores using PSCI firmware calls. If
+ disabled, the spin-table method is used instead.
+
endif
diff --git a/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk b/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
index c56bdeeea..a46937538 100644
--- a/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
+++ b/boot/boot-wrapper-aarch64/boot-wrapper-aarch64.mk
@@ -30,6 +30,12 @@ BOOT_WRAPPER_AARCH64_CONF_OPTS = \
--with-kernel-dir=$(LINUX_DIR) \
--with-cmdline=$(BR2_TARGET_BOOT_WRAPPER_AARCH64_BOOTARGS)
+ifeq ($(BR2_TARGET_BOOT_WRAPPER_AARCH64_PSCI),y)
+BOOT_WRAPPER_AARCH64_CONF_OPTS += --enable-psci
+else
+BOOT_WRAPPER_AARCH64_CONF_OPTS += --disable-psci
+endif
+
# We need to convince the configure script that the Linux kernel tree
# exists, as well as the DTB and the kernel Image. Even though those
# are available on the build machine, the configure script uses