summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorRaphaƫl Poggi <poggi.raph@gmail.com>2016-08-12 16:31:52 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-08-16 08:05:05 +0200
commitbbe71a699abc65492a677682af21aa43286af397 (patch)
tree1efef7b2058ed0947622e5f91b37ab04c1539202 /boot
parentefbd36a141c51cfbae83dd63f902654b247943d8 (diff)
barebox: fix ARCH value for arm64
barebox 2016.08 added arm64 support using ARCH=arm. [Peter: extend commit message to clarify] Signed-off-by: Raphael Poggi <poggi.raph@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/barebox/barebox.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 832297eef..7a110d214 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -61,6 +61,8 @@ else ifeq ($$(KERNEL_ARCH),x86_64)
$(1)_ARCH = x86
else ifeq ($$(KERNEL_ARCH),powerpc)
$(1)_ARCH = ppc
+else ifeq ($$(KERNEL_ARCH),arm64)
+$(1)_ARCH = arm
else
$(1)_ARCH = $$(KERNEL_ARCH)
endif