summaryrefslogtreecommitdiff
path: root/package/janus-gateway
diff options
context:
space:
mode:
authorAdam Duskett <Aduskett@gmail.com>2017-01-25 08:42:41 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-28 21:39:40 +1300
commit231884534b670cf87e24f872c3902008dce4b476 (patch)
treef135dd7252893038d1a7ced2ded746e507e2ed45 /package/janus-gateway
parent75175e4cd7cdc097d0b4d8bc1f67506d69e7b3b0 (diff)
janus-gateway: make streaming plugin optional
Currently janus-gateway is built by default with the streaming plugin. This causes a example config file to be placed on the target filing system that the user may not need or want, creates a 133K .so file on the target directory, and janus will also generate a warning when ran if the plugin does not have a matching configuration file setup by the user, as it will not use the example config file by default. This patch makes the streaming plugin optional. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/janus-gateway')
-rw-r--r--package/janus-gateway/Config.in3
-rw-r--r--package/janus-gateway/janus-gateway.mk6
2 files changed, 9 insertions, 0 deletions
diff --git a/package/janus-gateway/Config.in b/package/janus-gateway/Config.in
index c050edef8..16e98f8e4 100644
--- a/package/janus-gateway/Config.in
+++ b/package/janus-gateway/Config.in
@@ -33,6 +33,9 @@ config BR2_PACKAGE_JANUS_SIP_GATEWAY
bool "sip gateway"
select BR2_PACKAGE_SOFIA_SIP
+config BR2_PACKAGE_JANUS_STREAMING
+ bool "streaming"
+
endif
comment "janus-gateway needs a toolchain w/ dynamic library, threads, wchar"
diff --git a/package/janus-gateway/janus-gateway.mk b/package/janus-gateway/janus-gateway.mk
index a051e582a..96a81fea3 100644
--- a/package/janus-gateway/janus-gateway.mk
+++ b/package/janus-gateway/janus-gateway.mk
@@ -52,6 +52,12 @@ else
JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
endif
+ifeq ($(BR2_PACKAGE_JANUS_STREAMING),y)
+JANUS_GATEWAY_CONF_OPTS += --enable-plugin-streaming
+else
+JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
+endif
+
ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
JANUS_GATEWAY_DEPENDENCIES += libwebsockets
JANUS_GATEWAY_CONF_OPTS += --enable-websockets