summaryrefslogtreecommitdiff
path: root/package/janus-gateway
diff options
context:
space:
mode:
authorAdam Duskett <Aduskett@gmail.com>2017-01-25 08:42:42 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-28 21:39:40 +1300
commit8bb5a76c67ee949df391a7d6673feca18c6b54f3 (patch)
tree61a1940bc5531a343e5fbae7731abfd91c8b3382 /package/janus-gateway
parent231884534b670cf87e24f872c3902008dce4b476 (diff)
janus-gateway: make text room plugin optional
Currently janus-gateway is built by default with the text room plugin. This causes a example config file to be placed on the target filing system that the user may not need or want, creates a 63K .so file on the target directory, and janus will also generate a warning when ran if the plugin does not have a matching configuration file setup by the user, as it will not use the example config file by default. This patch makes the text room plugin optional. Signed-off-by: Adam Duskett <aduskett@codeblue.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/janus-gateway')
-rw-r--r--package/janus-gateway/Config.in3
-rw-r--r--package/janus-gateway/janus-gateway.mk6
2 files changed, 9 insertions, 0 deletions
diff --git a/package/janus-gateway/Config.in b/package/janus-gateway/Config.in
index 16e98f8e4..50e4dffb2 100644
--- a/package/janus-gateway/Config.in
+++ b/package/janus-gateway/Config.in
@@ -36,6 +36,9 @@ config BR2_PACKAGE_JANUS_SIP_GATEWAY
config BR2_PACKAGE_JANUS_STREAMING
bool "streaming"
+config BR2_PACKAGE_JANUS_TEXT_ROOM
+ bool "text room"
+
endif
comment "janus-gateway needs a toolchain w/ dynamic library, threads, wchar"
diff --git a/package/janus-gateway/janus-gateway.mk b/package/janus-gateway/janus-gateway.mk
index 96a81fea3..52acd5ccc 100644
--- a/package/janus-gateway/janus-gateway.mk
+++ b/package/janus-gateway/janus-gateway.mk
@@ -58,6 +58,12 @@ else
JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
endif
+ifeq ($(BR2_PACKAGE_JANUS_TEXT_ROOM),y)
+JANUS_GATEWAY_CONF_OPTS += --enable-plugin-textroom
+else
+JANUS_GATEWAY_CONF_OPTS += --disable-plugin-textroom
+endif
+
ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
JANUS_GATEWAY_DEPENDENCIES += libwebsockets
JANUS_GATEWAY_CONF_OPTS += --enable-websockets