summaryrefslogtreecommitdiff
path: root/package/vim
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-20 23:45:41 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 12:29:08 +0100
commit46b084368e4f3e4c98194fc108ce0aaa60b6820f (patch)
tree801f6dd22449823a454242ab391132e4daa59600 /package/vim
parentab0f1bf29bd861f3a2274a7c6755e40ddba0830c (diff)
package/vim: add optional support for acl
When acl was compiled before, vim will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/vim | grep NEEDED | sort 0x0000000000000001 (NEEDED) Shared library: [libacl.so.1] [...] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/vim')
-rw-r--r--package/vim/vim.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/vim/vim.mk b/package/vim/vim.mk
index 07493669d..6e05050f1 100644
--- a/package/vim/vim.mk
+++ b/package/vim/vim.mk
@@ -27,6 +27,13 @@ VIM_CONF_OPTS = --with-tlib=ncurses --enable-gui=no --without-x
VIM_LICENSE = Charityware
VIM_LICENSE_FILES = README.txt
+ifeq ($(BR2_PACKAGE_ACL),y)
+VIM_CONF_OPTS += --enable-acl
+VIM_DEPENDENCIES += acl
+else
+VIM_CONF_OPTS += --disable-acl
+endif
+
ifeq ($(BR2_PACKAGE_GPM),y)
VIM_CONF_OPTS += --enable-gpm
VIM_DEPENDENCIES += gpm