summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Widawsky <ben@bwidawsk.net>2011-06-24 11:42:03 -0700
committerBen Widawsky <ben@bwidawsk.net>2011-07-28 14:26:57 -0700
commit62873796c4a96554cc139e9aa49e25ce19cd65cd (patch)
tree94ec773aca3881e696bd6f1067ec16beb4056e9a /Makefile.am
parente39b13d7e4174ec50fd41d74fe8d3375c8ef2850 (diff)
intel-gpu-tools/debugging: shader debugger
high level summary of the files: * debug_rdata - get current state from debug registers. Helpful when developing the debugger, and could serve some purpose in the future. * eudb - the debugger itself * eviction_macro - generate the proper macro to flush the EU render cache until I get control flow working * pre_cpp - an evaluating c preprocesser like thing, to be used before cpp * sr - the system routine, exception handler which runs on the EU * test - a very basic test system routine * debug.h
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 78f63a42..9375823e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,4 +21,8 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = lib man tools scripts tests benchmarks
+if HAVE_SHADER_DEBUGGER
+SHADER_DEBUGGER_SUBDIR = debugger
+endif
+
+SUBDIRS = lib man tools scripts tests benchmarks $(SHADER_DEBUGGER_SUBDIR)