summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRodrigo Vivi <rodrigo.vivi@gmail.com>2013-02-05 16:17:54 -0200
committerDaniel Vetter <daniel.vetter@ffwll.ch>2013-02-06 12:40:06 +0100
commit7c170724003f42cd4ceea9f6c805292bbe2e81b2 (patch)
treeeb48002192d705a8c35b2c5ed5ac066305740399 /Makefile.am
parentc75b8c60b52cd75f756e59fcfd4ce971e9189509 (diff)
Build: Add --disable-tests configure flag to avoid tests build
Tests are still being built by default. However this request came from OSVs in order to allow them to include i-g-t in their distributions by default avoiding adding more and more dependencies since we are improving and adding more and more tests. v2: wait for Ben's spacing fixes and adjusted for new space rules. Signed-off-by: Rodrigo Vivi <rodrigo.vivi@gmail.com> Acked-by: Paul Menzel <paulepanter@users.sourceforge.net> Reviewed-by: Takashi Iwai <tiwai@suse.de> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ea0fd87..0dd615b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,12 +21,16 @@
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
-SUBDIRS = lib man tools scripts tests benchmarks demos
+SUBDIRS = lib man tools scripts benchmarks demos
if BUILD_SHADER_DEBUGGER
SUBDIRS += debugger
endif
+if BUILD_TESTS
+SUBDIRS += tests
+endif
+
test:
${MAKE} -C tests test