summaryrefslogtreecommitdiff
path: root/benchmarks/meson.build
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-05-23 12:55:09 +0100
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-11-22 11:19:23 +0000
commitb7f720e3d99bca8186a69d8fd50137aa30f9a4cc (patch)
treeedf89a45d5123379b0d0108030e411e1e7666f31 /benchmarks/meson.build
parent20d89b417e0bceb79cd80456838b1e91662d445e (diff)
gem_wsim: Busy stats balancers
Add busy and busy-avg balancers which make balancing decisions by looking at engine busyness via the i915 PMU. And thus are able to make decisions on the actual instantaneous load of the system, and not use metrics that lag behind by a batch or two. In doing so, each client should be able to greedily maximise their own usage of the system, leading to improved load balancing even in the face of other uncooperative clients. On the other hand, we are only using the instantaneous load without coupling in the predictive factor for dispatch and execution length. v2: * Commit text. (Chris Wilson) * Rename get_stats to get_pmu_stats. (Chris Wilson) * Fix PMU readout in VCS remap mode. v3: * Integrated Petri's meson build recipe. Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk> Cc: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'benchmarks/meson.build')
-rw-r--r--benchmarks/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/benchmarks/meson.build b/benchmarks/meson.build
index 9ab738f7..fa7f0764 100644
--- a/benchmarks/meson.build
+++ b/benchmarks/meson.build
@@ -31,6 +31,11 @@ endif
foreach prog : benchmark_progs
# FIXME meson doesn't like binaries with the same name
# meanwhile just suffix with _bench
+ link = []
+ if prog == 'gem_wsim'
+ link += lib_igt_perf
+ endif
executable(prog + '_bench', prog + '.c',
- dependencies : test_deps)
+ link_with : link,
+ dependencies : test_deps)
endforeach