summaryrefslogtreecommitdiff
path: root/benchmarks/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/meson.build')
-rw-r--r--benchmarks/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/benchmarks/meson.build b/benchmarks/meson.build
index 9ab738f7..fa7f0764 100644
--- a/benchmarks/meson.build
+++ b/benchmarks/meson.build
@@ -31,6 +31,11 @@ endif
foreach prog : benchmark_progs
# FIXME meson doesn't like binaries with the same name
# meanwhile just suffix with _bench
+ link = []
+ if prog == 'gem_wsim'
+ link += lib_igt_perf
+ endif
executable(prog + '_bench', prog + '.c',
- dependencies : test_deps)
+ link_with : link,
+ dependencies : test_deps)
endforeach