summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2018-06-21 14:06:24 +0300
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-06-25 09:32:08 +0300
commit9bbfbb1ce314578f18efe73b2cd74e877eb999fb (patch)
tree5bb730fa32519259a4540721dbcd969eff88e7dc /configure.ac
parent23d50a49413aff619d00ec50fc2e051e9b45baa5 (diff)
Make GLib mandatory
GLib was originally made optional for Android builds, and Android support was dropped a while ago due to lack of use and maintenance. Building without GLib was broken without bug reports anyway. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Daniel Vetter <daniel@ffwll.ch> Cc: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2f6bc70e..1ee4e90e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,10 +177,7 @@ PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3, AC_DEFINE(HAVE_XRANDR, 1, [Have libXran
# for testdisplay
PKG_CHECK_MODULES(CAIRO, [cairo >= 1.12.0])
PKG_CHECK_MODULES(LIBUDEV, [libudev])
-PKG_CHECK_MODULES(GLIB, [glib-2.0], [glib=yes], [glib=no])
-if test x"$glib" = xyes; then
- AC_DEFINE(HAVE_GLIB,1,[Enable glib support])
-fi
+PKG_CHECK_MODULES(GLIB, [glib-2.0])
PKG_CHECK_MODULES(GSL, [gsl], [gsl=yes], [gsl=no])
AM_CONDITIONAL(HAVE_GSL, [test "x$gsl" = xyes])
@@ -206,9 +203,6 @@ if test "x$enable_chamelium" = xyes; then
fi
PKG_CHECK_MODULES(PIXMAN, pixman-1, [],
[AC_MSG_ERROR([Failed to find pixman, required by chamelium.])])
- if test x"$glib" != xyes; then
- AC_MSG_ERROR([Failed to find glib, required by chamelium.])
- fi
if test x"$gsl" != xyes; then
AC_MSG_ERROR([Failed to find gsl, required by chamelium.])
fi