summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2f6bc70e..1ee4e90e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,10 +177,7 @@ PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3, AC_DEFINE(HAVE_XRANDR, 1, [Have libXran
# for testdisplay
PKG_CHECK_MODULES(CAIRO, [cairo >= 1.12.0])
PKG_CHECK_MODULES(LIBUDEV, [libudev])
-PKG_CHECK_MODULES(GLIB, [glib-2.0], [glib=yes], [glib=no])
-if test x"$glib" = xyes; then
- AC_DEFINE(HAVE_GLIB,1,[Enable glib support])
-fi
+PKG_CHECK_MODULES(GLIB, [glib-2.0])
PKG_CHECK_MODULES(GSL, [gsl], [gsl=yes], [gsl=no])
AM_CONDITIONAL(HAVE_GSL, [test "x$gsl" = xyes])
@@ -206,9 +203,6 @@ if test "x$enable_chamelium" = xyes; then
fi
PKG_CHECK_MODULES(PIXMAN, pixman-1, [],
[AC_MSG_ERROR([Failed to find pixman, required by chamelium.])])
- if test x"$glib" != xyes; then
- AC_MSG_ERROR([Failed to find glib, required by chamelium.])
- fi
if test x"$gsl" != xyes; then
AC_MSG_ERROR([Failed to find gsl, required by chamelium.])
fi