summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorPaul Kocialkowski <paul.kocialkowski@linux.intel.com>2017-08-21 18:27:19 +0300
committerLyude <lyude@redhat.com>2017-08-21 13:53:38 -0400
commit1579692d6447d126552b5fb020a63b26427c9a12 (patch)
tree4604cccc0b2b6edbf880b49ef4169875c8a9c14f /lib/Makefile.am
parent39cc9bf89c293c92d55aad803c08816ad922585d (diff)
lib: Add ALSA library with dedicated helpers
This introduces an ALSA library, with dedicated helpers for handling playback and capture. It handles ALSA device identification and configuration as well as a run loop with callback mechanisms for feeding output data and handling input data. This library paves the way for testing audio going through display connectors, such as HDMI. Signed-off-by: Paul Kocialkowski <paul.kocialkowski@linux.intel.com> Reviewed-by: Lyude Paul <lyude@redhat.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5ea08314..3ff14f66 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -38,6 +38,13 @@ lib_source_list += \
$(NULL)
endif
+if HAVE_ALSA
+lib_source_list += \
+ igt_alsa.c \
+ igt_alsa.h \
+ $(NULL)
+endif
+
AM_CPPFLAGS = -I$(top_srcdir)
AM_CFLAGS = \
$(CWARNFLAGS) \