summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2017-09-05 14:36:22 +0200
committerDaniel Vetter <daniel.vetter@ffwll.ch>2017-09-08 17:07:14 +0200
commit111c5857f1b349440f42fb1ce69e525ad72a727f (patch)
tree29c45b74812ed3434c2212b3fcfeedd9e9f89b4a /lib/meson.build
parent895236c6ead83ed537d762394c9930b1e82d8dde (diff)
meson: igt_frame also needs pixman
Oversight I noticed because I have the deps for chamelium on the other machine already. Acked-by: Jani Nikula <jani.nikula@intel.com> Acked-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Acked-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Daniel Stone <daniels@collabora.com> Acked-by: Radoslaw Szwichtenberg <radoslaw.szwichtenberg@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/meson.build b/lib/meson.build
index f0672edf..b78e42dc 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -117,8 +117,8 @@ if valgrind.found()
lib_deps += valgrind
endif
-if gsl.found()
- lib_deps += gsl
+if gsl.found() and pixman.found()
+ lib_deps += [ gsl, pixman ]
lib_headers += [ 'igt_frame.h', 'igt_audio.h' ]
lib_sources += [ 'igt_frame.c', 'igt_audio.c' ]
endif