summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorVille Syrjälä <ville.syrjala@linux.intel.com>2017-09-15 16:54:44 +0300
committerVille Syrjälä <ville.syrjala@linux.intel.com>2017-09-18 16:08:53 +0300
commit2e93946e4e15cb8e7e978334cb62677f9ead82fe (patch)
tree4bc26126df7256dd349fa189f6bf0452d2d9e837 /lib/meson.build
parente418dbba0c34233e56246ffd2152e174c7481e03 (diff)
meson: Fix IGT_GIT_SHA1 handling
Tell meson about the dependency on version.h. Avoids the compiler falling over on account of IGT_GIT_SHA1 not being there. Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 0d379d90..203be520 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -140,9 +140,9 @@ install_headers(lib_headers)
pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'intel-gpu-tools')
srcdir = join_paths(meson.source_root(), 'tests')
-vcs_tag(input : 'version.h.in', output : 'version.h',
- fallback : 'NO-GIT',
- command : [ 'git', 'log', '-n1', '--pretty=format:g%h' ] )
+lib_version = vcs_tag(input : 'version.h.in', output : 'version.h',
+ fallback : 'NO-GIT',
+ command : [ 'git', 'log', '-n1', '--pretty=format:g%h' ] )
lib_intermediates = []
foreach f: lib_sources
@@ -154,7 +154,7 @@ foreach f: lib_sources
endif
lib = static_library('igt-' + name,
- f,
+ [ f, lib_version ],
include_directories: inc,
dependencies : lib_deps,
c_args : [