summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 0d379d90..203be520 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -140,9 +140,9 @@ install_headers(lib_headers)
pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'intel-gpu-tools')
srcdir = join_paths(meson.source_root(), 'tests')
-vcs_tag(input : 'version.h.in', output : 'version.h',
- fallback : 'NO-GIT',
- command : [ 'git', 'log', '-n1', '--pretty=format:g%h' ] )
+lib_version = vcs_tag(input : 'version.h.in', output : 'version.h',
+ fallback : 'NO-GIT',
+ command : [ 'git', 'log', '-n1', '--pretty=format:g%h' ] )
lib_intermediates = []
foreach f: lib_sources
@@ -154,7 +154,7 @@ foreach f: lib_sources
endif
lib = static_library('igt-' + name,
- f,
+ [ f, lib_version ],
include_directories: inc,
dependencies : lib_deps,
c_args : [