summaryrefslogtreecommitdiff
path: root/lib/tests/meson.build
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2019-02-19 08:57:16 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2019-02-20 13:58:04 +0100
commit091cf55736d7df8ee2984b94086e34185b11276f (patch)
tree2e3a4cc314a23caf942866ea3fa6cddb555c5069 /lib/tests/meson.build
parent84096969b59b3230a4f890109eb3c6406a37255b (diff)
lib/tests: Add testcase for nonexisting subtest name
While at it, convert the existing testcase for invalid subtest names to a positive one. This is the only thing the invalid subtest checking for all tests did cover, which wasn't covered through some other checks already. Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
Diffstat (limited to 'lib/tests/meson.build')
-rw-r--r--lib/tests/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/tests/meson.build b/lib/tests/meson.build
index 776b63ed..74efce39 100644
--- a/lib/tests/meson.build
+++ b/lib/tests/meson.build
@@ -7,6 +7,7 @@ lib_tests = [
'igt_fork_helper',
'igt_hdmi_inject',
'igt_list_only',
+ 'igt_invalid_subtest_name',
'igt_no_exit',
'igt_segfault',
'igt_simulation',
@@ -18,7 +19,6 @@ lib_fail_tests = [
'igt_no_subtest',
'igt_simple_test_subtests',
'igt_timeout',
- 'igt_invalid_subtest_name',
]
foreach lib_test : lib_tests