summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-02-20 11:00:22 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-02-23 12:22:33 +0200
commitf9b6fd624be9692e9a892c0976fa72cedefc9fed (patch)
tree7213982cb946bfb74e42ccbd1347eca8caf79931 /meson.build
parent4d2af5c79d60d6dcdba0bfdddf7d73ab6ac78f89 (diff)
meson: Make cairo mandatory
We use cairo all around the codebase unconditionally, yet for some reason it was an optional dependency. Cc: Petri Latvala <petri.latvala@intel.com> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Acked-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9036feb1..509ae5de 100644
--- a/meson.build
+++ b/meson.build
@@ -47,7 +47,7 @@ if valgrind.found()
config.set('HAVE_VALGRIND', 1)
endif
-cairo = dependency('cairo', version : '>1.12.0', required : false)
+cairo = dependency('cairo', version : '>1.12.0', required : true)
libudev = dependency('libudev', required : false)
if libudev.found()