summaryrefslogtreecommitdiff
path: root/overlay/Makefile.am
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2017-12-18 23:00:54 +0000
committerLionel Landwerlin <lionel.g.landwerlin@intel.com>2017-12-22 11:17:37 +0000
commit865a47ca2b93b208ba016f3c4fc00831ec7bfec6 (patch)
treefae09896c77b2d7c3ccd9989e23d5dc041442888 /overlay/Makefile.am
parentbeb26d89ff5c5621c1e6b6ac2a45439507af86b7 (diff)
overlay: parse tracepoints from sysfs to figure out fields' location
With changes going to drm-tip, the tracepoints field locations are going to change. This change introduces a tracepoint parser (using a peg parser) which lets us figure out field positions on the fly. v2: Fix automake build (Lionel) v3: Make overlay build conditional on peg (Petri) Make wait_end callback more readable (Chris) Drop tracepoint_id(), instead parsing from format file (Lionel) v4: Fix existing configure.ac issue with overlay build (Petri) v5: Silence unused function (Lionel) v6: Fix missing double quote in v4 (Lionel) Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Acked-by: Chris Wilson <chris@chris-wilson.co.uk> For the build system changes: Acked-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'overlay/Makefile.am')
-rw-r--r--overlay/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/overlay/Makefile.am b/overlay/Makefile.am
index fca04cae..0f553b7c 100644
--- a/overlay/Makefile.am
+++ b/overlay/Makefile.am
@@ -1,7 +1,12 @@
if BUILD_OVERLAY
bin_PROGRAMS = intel-gpu-overlay
+
+BUILT_SOURCES = tracepoint_format.h
endif
+tracepoint_format.h: tracepoint_format.leg
+ $(LEG) -o $@ $<
+
AM_CPPFLAGS = -I. -I$(top_srcdir)/include/drm-uapi
AM_CFLAGS = $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) \
$(CAIRO_CFLAGS) $(OVERLAY_CFLAGS) $(WERROR_CFLAGS) -I$(srcdir)/../lib