summaryrefslogtreecommitdiff
path: root/overlay/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'overlay/Makefile.am')
-rw-r--r--overlay/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/overlay/Makefile.am b/overlay/Makefile.am
index fca04cae..0f553b7c 100644
--- a/overlay/Makefile.am
+++ b/overlay/Makefile.am
@@ -1,7 +1,12 @@
if BUILD_OVERLAY
bin_PROGRAMS = intel-gpu-overlay
+
+BUILT_SOURCES = tracepoint_format.h
endif
+tracepoint_format.h: tracepoint_format.leg
+ $(LEG) -o $@ $<
+
AM_CPPFLAGS = -I. -I$(top_srcdir)/include/drm-uapi
AM_CFLAGS = $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) \
$(CAIRO_CFLAGS) $(OVERLAY_CFLAGS) $(WERROR_CFLAGS) -I$(srcdir)/../lib