summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2017-11-10 12:39:56 -0800
committerEric Anholt <eric@anholt.net>2017-11-21 09:52:52 -0800
commitd21e95ca81da6f9332999ceebe6b42e4425d3bb6 (patch)
treeec5ea9f9fb7aba73bbed7836be9d7668e3a45b6b /tests/meson.build
parent4eb53c7cc02a36a23c33f786cb20bf078719f40e (diff)
tests: Remove libdrm_vc4 dependency.
The autotools build retains the configure.ac option, while meson folds vc4 into the default build since we don't have any meson_options.txt to control parts of the build. Signed-off-by: Eric Anholt <eric@anholt.net> Acked-by: Petri Latvala <petri.latvala@intel.com> Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build16
1 files changed, 5 insertions, 11 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 20ff79dc..eb64f959 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -213,6 +213,11 @@ test_progs = [
'syncobj_wait',
'template',
'tools_test',
+ 'vc4_create_bo',
+ 'vc4_dmabuf_poll',
+ 'vc4_lookup_fail',
+ 'vc4_wait_bo',
+ 'vc4_wait_seqno',
'vgem_basic',
'vgem_slow',
]
@@ -238,17 +243,6 @@ if libdrm_nouveau.found()
test_deps += libdrm_nouveau
endif
-if libdrm_vc4.found()
- test_progs += [
- 'vc4_create_bo',
- 'vc4_dmabuf_poll',
- 'vc4_lookup_fail',
- 'vc4_wait_bo',
- 'vc4_wait_seqno',
- ]
- test_deps += libdrm_vc4
-endif
-
if chamelium.found()
test_progs += [
'kms_chamelium',