summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e22703d0..a3f541a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,12 +58,12 @@ AX_GCC_FUNC_ATTRIBUTE([constructor])
dnl Check for POSIX timers
AC_CHECK_FUNCS(timer_create, [], [
AC_CHECK_LIB(rt, timer_create, [
- AC_DEFINE(HAVE_TIMER_CREATE, 1)
TIMER_LIBS="-lrt"
], [
AC_CHECK_LIB(pthread, timer_create, [
- AC_DEFINE(HAVE_TIMER_CREATE, 1)
TIMER_LIBS="-lpthread"
+ ], [
+ AC_MSG_ERROR([Failed to find library containing timer_create.])
])
])
])