summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2019-03-01 10:25:58 +0000
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2019-03-04 07:01:17 +0000
commita958d3f60b7718151fd0bafcdd1e4874262f51b8 (patch)
tree1d4145b78196e4734d8d00419d21d569b49a5f33 /configure.ac
parenta117a5b819a76894fcee02a7cc134aa2b1249c78 (diff)
automake: Make librt mandatory
librt is required by libintel_tools so express it as mandatory in autoconf and also drop explicit mentions from Makefile.am. This also fixes a build warning of: tests/Makefile.am:134: warning: variable 'pm_rc6_residency_LDADD' is defined but no program or tests/Makefile.am:134: library has 'pm_rc6_residency' as canonical name (possible typo) Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e22703d0..a3f541a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,12 +58,12 @@ AX_GCC_FUNC_ATTRIBUTE([constructor])
dnl Check for POSIX timers
AC_CHECK_FUNCS(timer_create, [], [
AC_CHECK_LIB(rt, timer_create, [
- AC_DEFINE(HAVE_TIMER_CREATE, 1)
TIMER_LIBS="-lrt"
], [
AC_CHECK_LIB(pthread, timer_create, [
- AC_DEFINE(HAVE_TIMER_CREATE, 1)
TIMER_LIBS="-lpthread"
+ ], [
+ AC_MSG_ERROR([Failed to find library containing timer_create.])
])
])
])