summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Raeman <draeman@bbn.com>2016-07-25 15:52:27 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-26 00:01:14 +0200
commit5ca9b7cf66941a66cff736aadaf8a31afe55f964 (patch)
treeb427f48cb79aedbd03484153321a7d6d9ebcce80
parent6f8162cf8c1abef7e0a4771fe0d6b26a28f5c2b6 (diff)
dtc: install libfdt library and headers for host variant
The dtc package currently does not install libfdt for the host install. It can be useful to have libfdt on the host, such as for building QEMU with the --enable-fdt configure switch. Signed-off-by: David Raeman <draeman@bbn.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/dtc/dtc.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/dtc/dtc.mk b/package/dtc/dtc.mk
index 8fdcdbed7..febd5920c 100644
--- a/package/dtc/dtc.mk
+++ b/package/dtc/dtc.mk
@@ -51,7 +51,9 @@ define HOST_DTC_BUILD_CMDS
endef
define HOST_DTC_INSTALL_CMDS
- $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin
+ $(MAKE) -C $(@D) PREFIX=$(HOST_DIR)/usr install-bin install-lib \
+ install-includes
+
endef
$(eval $(generic-package))