summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-17 15:33:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-17 16:13:05 +0200
commit24c75fbb38ffeb5c5a7278cf40f4f7cf867502e0 (patch)
tree410383da6bd1b3b01b7e9cdaead1d7a2889c8e9c /Makefile
parent598c80be8fc7b5ddfcba6f7715d90757033723ef (diff)
Makefile: implement a graph-size target
This commit implements a graph-size target that calls the script of the same name to generate the graph and CSV files related to package and file sizes. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 181d44685..c871393b7 100644
--- a/Makefile
+++ b/Makefile
@@ -686,6 +686,13 @@ graph-depends: graph-depends-requirements
|tee $(GRAPHS_DIR)/$(@).dot \
|dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(GRAPHS_DIR)/$(@).$(BR_GRAPH_OUT)
+graph-size:
+ $(Q)mkdir -p $(GRAPHS_DIR)
+ $(Q)$(TOPDIR)/support/scripts/size-stats --builddir $(BASE_DIR) \
+ --graph $(GRAPHS_DIR)/graph-size.$(BR_GRAPH_OUT) \
+ --file-size-csv $(GRAPHS_DIR)/file-size-stats.csv \
+ --package-size-csv $(GRAPHS_DIR)/package-size-stats.csv
+
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
all: menuconfig
@@ -903,6 +910,7 @@ endif
@echo ' manual-epub - build manual in ePub'
@echo ' graph-build - generate graphs of the build times'
@echo ' graph-depends - generate graph of the dependency tree'
+ @echo ' graph-size - generate stats of the filesystem size'
@echo ' list-defconfigs - list all defconfigs (pre-configured minimal systems)'
@echo
@echo 'Miscellaneous:'