summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 181d44685..c871393b7 100644
--- a/Makefile
+++ b/Makefile
@@ -686,6 +686,13 @@ graph-depends: graph-depends-requirements
|tee $(GRAPHS_DIR)/$(@).dot \
|dot $(BR2_GRAPH_DOT_OPTS) -T$(BR_GRAPH_OUT) -o $(GRAPHS_DIR)/$(@).$(BR_GRAPH_OUT)
+graph-size:
+ $(Q)mkdir -p $(GRAPHS_DIR)
+ $(Q)$(TOPDIR)/support/scripts/size-stats --builddir $(BASE_DIR) \
+ --graph $(GRAPHS_DIR)/graph-size.$(BR_GRAPH_OUT) \
+ --file-size-csv $(GRAPHS_DIR)/file-size-stats.csv \
+ --package-size-csv $(GRAPHS_DIR)/package-size-stats.csv
+
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
all: menuconfig
@@ -903,6 +910,7 @@ endif
@echo ' manual-epub - build manual in ePub'
@echo ' graph-build - generate graphs of the build times'
@echo ' graph-depends - generate graph of the dependency tree'
+ @echo ' graph-size - generate stats of the filesystem size'
@echo ' list-defconfigs - list all defconfigs (pre-configured minimal systems)'
@echo
@echo 'Miscellaneous:'