summaryrefslogtreecommitdiff
path: root/package/avrdude
diff options
context:
space:
mode:
authorWojciech M. Zabolotny <wzab01@gmail.com>2013-12-24 23:38:00 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-28 17:07:27 +0100
commitdc776f0d0546900b22d1552f3e522be2080016c6 (patch)
treef145dfe399b3eecf253d21daf146e378d0882e87 /package/avrdude
parenta4f194c83d0092bf1f0310857f702a833fe4dcab (diff)
avrdude: new package
[Thomas: - remove empty newline at the end of Config.in - use lowercase for the package name in the comment header - reword the comment explaining why autoreconf is needed - add optional dependency on libftdi, which avrdude can use - remove avrdude.conf.bak file from /etc] Signed-off-by: Wojciech M. Zabolotny <wzab01@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/avrdude')
-rw-r--r--package/avrdude/Config.in15
-rw-r--r--package/avrdude/avrdude.mk30
2 files changed, 45 insertions, 0 deletions
diff --git a/package/avrdude/Config.in b/package/avrdude/Config.in
new file mode 100644
index 000000000..8eac014a3
--- /dev/null
+++ b/package/avrdude/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_AVRDUDE
+ bool "avrdude"
+ select BR2_PACKAGE_LIBELF
+ select BR2_PACKAGE_LIBUSB
+ select BR2_PACKAGE_LIBUSB_COMPAT
+ select BR2_PACKAGE_NCURSES
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ avrdude is a programmer for Atmel AVR microcontrollers
+ this package provides a version with new linuxspi driver
+
+ https://github.com/kcuzner/avrdude
+
+comment "avrdude needs a toolchain w/ threads"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/avrdude/avrdude.mk b/package/avrdude/avrdude.mk
new file mode 100644
index 000000000..338d61c39
--- /dev/null
+++ b/package/avrdude/avrdude.mk
@@ -0,0 +1,30 @@
+################################################################################
+#
+# avrdude
+#
+################################################################################
+
+AVRDUDE_VERSION = eabe067c4527bc2eedc5db9288ef5cf1818ec720
+AVRDUDE_SITE = $(call github,kcuzner,avrdude,$(AVRDUDE_VERSION))
+AVRDUDE_LICENSE = GPLv2+
+AVRDUDR_LICENSE_FILES = avrdude/COPYING
+AVRDUDE_SUBDIR = avrdude
+# Sources coming from git, without generated configure and Makefile.in
+# files.
+AVRDUDE_AUTORECONF = YES
+AVRDUDE_DEPENDENCIES = libelf libusb libusb-compat ncurses
+
+ifeq ($(BR2_PACKAGE_LIBFTDI),y)
+AVRDUDE_DEPENDENCIES += libftdi
+endif
+
+# if /etc/avrdude.conf exists, the installation process creates a
+# backup file, which we do not want in the context of Buildroot.
+define AVRDUDE_REMOVE_BACKUP_FILE
+ $(RM) -f $(TARGET_DIR)/etc/avrdude.conf.bak
+endef
+
+AVRDUDE_POST_INSTALL_TARGET_HOOKS += AVRDUDE_REMOVE_BACKUP_FILE
+
+$(eval $(autotools-package))
+