summaryrefslogtreecommitdiff
path: root/package/gdb/gdb.mk
diff options
context:
space:
mode:
authorVincent Stehlé <vincent.stehle@laposte.net>2014-09-15 22:50:07 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-16 22:25:40 +0200
commitca40efb4bde3816cbf0307701f8bc7b5f386be6e (patch)
tree631a6dfb724c8439872b2124cda978bfdb7edebf /package/gdb/gdb.mk
parentc5579a0ea19e2290a59b301f5d320d3a1d07dcea (diff)
gdb: enable tui support for target package
Add a configuration option to compile the gdb target package with the --enable-tui switch. This is done pretty much in the same way as in commit 2474fb0bf1a7 ("host-gdb: enable terminal user interface support"), but for the gdb package on target. This makes sense only when a full debugger is installed on target, not for a gdbserver. [Thomas: remove "default n" since this is the default, adjust the prompt of the option, and rewrap the help text.] Signed-off-by: Vincent Stehlé <vincent.stehle@laposte.net> Cc: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gdb/gdb.mk')
-rw-r--r--package/gdb/gdb.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 41d3689c8..4a194e26b 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -76,7 +76,6 @@ GDB_CONF_ENV = \
GDB_CONF_OPT = \
--without-uiout \
- --disable-tui \
--disable-gdbtk \
--without-x \
--disable-sim \
@@ -86,6 +85,12 @@ GDB_CONF_OPT = \
--without-included-gettext \
--disable-werror
+ifeq ($(BR2_PACKAGE_GDB_TUI),y)
+ GDB_CONF_OPT += --enable-tui
+else
+ GDB_CONF_OPT += --disable-tui
+endif
+
# This removes some unneeded Python scripts and XML target description
# files that are not useful for a normal usage of the debugger.
define GDB_REMOVE_UNNEEDED_FILES