summaryrefslogtreecommitdiff
path: root/package/rpm
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-01-18 20:53:09 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-01 23:13:24 +0100
commit61c3fbd10bee7784d871b84412aa9d488040a4f3 (patch)
treef40c89ac4a6e4460892bc876f76cc89bc5ac9720 /package/rpm
parent3c476540d17aaa629aa67bc754f1f67233d20aed (diff)
package/rpm: use external xz library
Internal xz backend is statically linked and need a static libintl library when BR2_NEEDS_GETTEXT_IF_LOCALE is set. But for a shared only build, there is no static libintl available in the sysroot. Use the external xz library provided by Buildroot instead of using the internal xz backend. Fixes: http://autobuild.buildroot.net/results/2c6/2c61562008418ff58fa3085a3342b0e304923073/ Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/rpm')
-rw-r--r--package/rpm/rpm.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
index 68d964afc..fda10f224 100644
--- a/package/rpm/rpm.mk
+++ b/package/rpm/rpm.mk
@@ -46,7 +46,10 @@ endif
# xz payload support needs a toolchain w/ C++
ifeq ($(BR2_PACKAGE_XZ)$(BR2_INSTALL_LIBSTDCPP),yy)
-RPM_CONF_OPTS += --with-xz
+RPM_DEPENDENCIES += xz
+RPM_CONF_OPTS += --with-xz=external
+else
+RPM_CONF_OPTS += --with-xz=none
endif
ifeq ($(BR2_PACKAGE_BZIP2),y)