summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-12-03 13:17:37 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 16:22:11 +0100
commit3909197ace8db3f6e61c5e025fb43266968b3435 (patch)
tree2e566620233722305a97a9584be061863fa7b778 /package
parentee586c356de65ffe10473fff471c1951208f6a64 (diff)
package/aubio: add jack2 optional dependency
Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/aubio/aubio.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
index ed00088a6..7aac6e547 100644
--- a/package/aubio/aubio.mk
+++ b/package/aubio/aubio.mk
@@ -15,7 +15,6 @@ AUBIO_CONF_OPTS = \
--disable-docs \
--disable-atlas \
--disable-avcodec \
- --disable-jack \
--disable-fftw3 \
--disable-fftw3f
@@ -33,4 +32,11 @@ else
AUBIO_CONF_OPTS += --disable-samplerate
endif
+ifeq ($(BR2_PACKAGE_JACK2),y)
+AUBIO_DEPENDENCIES += jack2
+AUBIO_CONF_OPTS += --enable-jack
+else
+AUBIO_CONF_OPTS += --disable-jack
+endif
+
$(eval $(waf-package))