summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-12-03 13:17:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 16:22:09 +0100
commitee586c356de65ffe10473fff471c1951208f6a64 (patch)
tree6959223e4edf42f4faf07a56502a71eb9ac7ec82 /package
parent06d8abd0908524d6623958612e5ba8093ab5d921 (diff)
package/aubio: add libsamplerate optional dependency
Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/aubio/aubio.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
index e1694ab64..ed00088a6 100644
--- a/package/aubio/aubio.mk
+++ b/package/aubio/aubio.mk
@@ -14,7 +14,6 @@ AUBIO_INSTALL_STAGING = YES
AUBIO_CONF_OPTS = \
--disable-docs \
--disable-atlas \
- --disable-samplerate \
--disable-avcodec \
--disable-jack \
--disable-fftw3 \
@@ -27,4 +26,11 @@ else
AUBIO_CONF_OPTS += --disable-sndfile
endif
+ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
+AUBIO_DEPENDENCIES += libsamplerate
+AUBIO_CONF_OPTS += --enable-samplerate
+else
+AUBIO_CONF_OPTS += --disable-samplerate
+endif
+
$(eval $(waf-package))