summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-12-03 13:17:38 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 16:22:12 +0100
commit5812e3989336fb8fbfb114096e36da43730ccfcd (patch)
tree9ba884e7cab32d5b89fa5e925cf826d9260bef35 /package
parent3909197ace8db3f6e61c5e025fb43266968b3435 (diff)
package/aubio: add fftw optional dependency
Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/aubio/aubio.mk16
1 files changed, 13 insertions, 3 deletions
diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
index 7aac6e547..9339f4495 100644
--- a/package/aubio/aubio.mk
+++ b/package/aubio/aubio.mk
@@ -14,9 +14,7 @@ AUBIO_INSTALL_STAGING = YES
AUBIO_CONF_OPTS = \
--disable-docs \
--disable-atlas \
- --disable-avcodec \
- --disable-fftw3 \
- --disable-fftw3f
+ --disable-avcodec
ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
AUBIO_DEPENDENCIES += libsndfile
@@ -39,4 +37,16 @@ else
AUBIO_CONF_OPTS += --disable-jack
endif
+ifeq ($(BR2_PACKAGE_FFTW),y)
+AUBIO_DEPENDENCIES += fftw
+# fftw3 require double otherwise it will look for fftw3f
+ifeq ($(BR2_PACKAGE_FFTW_PRECISION_DOUBLE),y)
+AUBIO_CONF_OPTS += --enable-fftw3 --enable-double
+else ifeq ($(BR2_PACKAGE_FFTW_PRECISION_SINGLE),y)
+AUBIO_CONF_OPTS += --enable-fftw3f --disable-double
+endif
+else # !BR2_PACKAGE_FFTW
+AUBIO_CONF_OPTS += --disable-fftw3
+endif
+
$(eval $(waf-package))