summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2018-07-26 21:08:44 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2018-07-27 14:01:23 +0100
commitff91dbc87eece221626b184ce33f5b4e62d0d319 (patch)
tree7f5107d2e14d150cb87377fb384fdd6820fc96b6 /tests/meson.build
parentb051e16eba17cb7eb36c141db6992830894542db (diff)
igt/gem_mocs_settings: Use i915_pmu to measure rc6 residency
Use the perf pmu interface for lowlevel rc6 measurement, hopefully for greater stability. v2: Fix timeout to run for 1s, not one pass! Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Reviewed-by: Matthew Auld <matthew.auld@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index c1f9fa07..83b2732f 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -82,7 +82,6 @@ test_progs = [
'gem_mmap_gtt',
'gem_mmap_offset_exhaustion',
'gem_mmap_wc',
- 'gem_mocs_settings',
'gem_partial_pwrite_pread',
'gem_persistent_relocs',
'gem_pipe_control_store_loop',
@@ -279,6 +278,13 @@ test_executables += executable('gem_eio', 'gem_eio.c',
install : true)
test_progs += 'gem_eio'
+test_executables += executable('gem_mocs_settings', 'gem_mocs_settings.c',
+ dependencies : test_deps + [ lib_igt_perf ],
+ install_dir : libexecdir,
+ install_rpath : rpathdir,
+ install : true)
+test_progs += 'gem_mocs_settings'
+
test_executables += executable('perf_pmu', 'perf_pmu.c',
dependencies : test_deps + [ lib_igt_perf ],
install_dir : libexecdir,